Для работы dapp требуется:

Ruby

Версия >= 2.1.

Установка ruby с помощью rvm

Docker

Версия >= 1.10.0.

Установка docker

Заголовочные файлы libssh2 для работы с git-репозиториями через ssh

Ubuntu

apt-get install libssh2-1-dev

Centos

yum install libssh2-devel

Cmake для установки зависимого gem rugged

Ubuntu

apt-get install cmake

Centos

yum install cmake

Gem dapp

gem install dapp